您的位置:首页 > 其它

hdu 1208 Pascal's Travels (子状态继承dp)

2015-03-28 12:30 405 查看


Pascal's Travels

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1774 Accepted Submission(s): 781



Problem Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away
from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further
progress.

Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.



Figure 1



Figure 2

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed
by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board.

Sample Input

4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1


Sample Output

3
0
7


简单dp,从起点开始每次走到一个格子,记下到达该点的原路线数目加上这次的路线数目,重复执行。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<map>
using namespace std;
#define N 100
#define ll __int64
const int inf=0x7fffffff;
ll a

;
ll dp

;
char s

;
int main()
{
int i,j,n,u,v,t;
while(scanf("%d",&n),n!=-1)
{
for(i=0;i<n;i++)
scanf("%s",s[i]);
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
a[i][j]=s[i][j]-'0';
dp[i][j]=0;
}
}
dp[0][0]=1;
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
if(i==n-1&&j==n-1)      //到达终点,防止累加错误
continue;
if(!dp[i][j]||!a[i][j])  //此路不通
continue;
t=a[i][j];          //每一步都只能直走,中途不能拐弯
u=i+t;
v=j;
if(u<n&&v<n)
{
dp[u][v]+=dp[i][j];
}
u=i;
v=j+t;
if(u<n&&v<n)
{
dp[u][v]+=dp[i][j];
}
}
}
printf("%I64d\n",dp[n-1][n-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: