您的位置:首页 > 其它

数学 hdu 1719

2015-03-27 13:58 197 查看

Friend

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2010 Accepted Submission(s): 1014

Problem Description
Friend number are defined recursively as follows.

(1) numbers 1 and 2 are friend number;

(2) if a and b are friend numbers, so is ab+a+b;

(3) only the numbers defined in (1) and (2) are friend number.

Now your task is to judge whether an integer is a friend number.



Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.



Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.



Sample Input
3
13121
12131




Sample Output
YES!
YES!
NO!




Source
2007省赛集训队练习赛(2)

方程可以转化为 (a+1)*(b+1)=n+1;

//考查知识点:数学推导。。 
#include<stdio.h>
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		if(n==0)
		{
			printf("NO!\n");
			continue;
		}
		n++;
		while(n%3==0||n%2==0)
		{
			if(n%3==0)
			n/=3;
			if(n%2==0)
			n/=2;
		}
		if(n==1)
		printf("YES!\n");
		else
		puts("NO!");
	} 
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: