您的位置:首页 > 其它

POJ 1163 The Triangle (线性dp)

2015-03-26 15:56 375 查看
The Triangle
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 39423Accepted: 23715
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally
down to the right.

Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in
the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output
30

Source
IOI 1994

题目链接:http://poj.org/problem?id=1163

题目大意:给一个数字三角形,从上往下每次可以选择向左下或者向右下,每到一个点则该路径加上该点的值,求到最下面一层路径值的最大值

题目分析:因为越往上数字越少,我们考虑从下往上进行动态规划,dp[i][j] = val[i][j] + max(dp[i + 1][j + 1], dp[i + 1][j]),初始化dp[n - 1][j] = val[n - 1][j],最后dp[0][0]就是答案

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 105;
int dp[MAX][MAX], val[MAX][MAX];

int main()
{
    int n;
    memset(dp, 0, sizeof(dp));
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
        for(int j = 0; j <= i; j++)
            scanf("%d", &val[i][j]);
    for(int j = 0; j < n; j++)
        dp[n - 1][j] = val[n - 1][j];
    for(int i = n - 1; i >= 0; i--)
        for(int j = 0; j <= i; j++)
            dp[i][j] = val[i][j] + max(dp[i + 1][j + 1], dp[i + 1][j]);
    printf("%d\n", dp[0][0]);
}


dp的路好难走,越难越要走
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: