您的位置:首页 > 其它

HDOJ 1003 Max Sum(新手动态规划)

2015-03-25 22:13 363 查看


Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 162353 Accepted Submission(s): 38007



Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.



Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).



Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.



Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5




Sample Output

Case 1:
14 1 4

Case 2:
7 1 6




初次接触到DP,在百度上找了一篇动态规划的文章看了一下。虽然学不到什么具体的东西,但也有助于新手认识和理解
DP。传送门:我是红领巾,不用谢

此题就是找出序列中的最大和子串。看到一个很好的解释,有助于理解,粘贴如下:

要找出和最大的子段,首先想到的是枚举,枚举的方法是,分别将数串中的每一个数作为子段的第一位数,然后子段长度依次递增。例如:
(2,-3,4,-1)这个数串枚举的所有情况为:

以2作为子段的第一位: 2,(2,-3),(2,-3,4),(2,-3,4,-1)。

以-3作为子段的第一位: -3,(-3,4),(-3,4,-1)。

以4作为子段的第一位: 4,(4,-1)。

以-1作为子段的第一位: -1 。

从枚举的过程中发现:

当前子段和的值为负值时,就没必要再往下进行,而应将下一位数作为子段的第一位。也就是说,当处理第i个数时,如果以第i-1个数为结尾的子段的和为正数,则不必将第i个数作为新子段的首位进行枚举,因为新子段加上前面子段和所得的正数,一定能得到更大的子段和。

根据以上思路,AC代码如下:

<span style="font-size:18px;">#include<stdio.h>
int main()
{
	int t,n,temp,max,start,end,i,k=0,num,sum;
	scanf("%d",&t);
	while(t--)
	{
		k++;
		max=-1000;temp=1;sum=0;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&num);
			sum=sum+num;
			if(sum>max)//只有sum值大于max值时,才延长子串长度,否则一直储存着之前所得的最大子串信息 
			{
				max=sum;
				start=temp;
				end=i;
			}
			if(sum<0)//若sum值小于零,则将下一个数作为新子串的首位 
			{
				sum=0;
				temp=i+1;
			}
		}
		printf("Case %d:\n%d %d %d\n",k,max,start,end);
		if(t!=0)
		   printf("\n");
	}
	return 0;
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: