您的位置:首页 > 其它

HDOJ 题目2680 Choose the best route(spfa)

2015-03-25 12:05 316 查看


Choose the best route

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8248 Accepted Submission(s): 2714



Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take.
You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1


Sample Output

1
-1


Author

dandelion

Source

2009浙江大学计算机研考复试(机试部分)——全真模拟

Recommend

lcy | We have carefully selected several similar problems for you: 2722 2962 2433 2482 1482

水,而且才1000个点

ac代码

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
#define INF 0xfffffff
using namespace std;
int n,m,s,head[1010],cnt,dis[1010],vis[1010];
struct s
{
int u,v,w,next;
}edge[20020];
void add(int u,int v,int w)
{
edge[cnt].u=u;
edge[cnt].v=v;
edge[cnt].w=w;
edge[cnt].next=head[u];
head[u]=cnt++;
}
void spfa()
{
int i;
memset(vis,0,sizeof(vis));
for(i=1;i<=n;i++)
{
dis[i]=INF;
}
dis[s]=0;
queue<int>q;
q.push(s);
vis[s]=1;
while(!q.empty())
{
int u=q.front();
q.pop();
vis[u]=0;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].v;
if(dis[v]>dis[u]+edge[i].w)
{
dis[v]=dis[u]+edge[i].w;
if(!vis[v])
{
vis[v]=1;
q.push(v);
}
}
}
}
}
int main()
{
//int n,m,s;
while(scanf("%d%d%d",&n,&m,&s)!=EOF)
{
int i;
memset(head,-1,sizeof(head));
cnt=0;
for(i=0;i<m;i++)
{
int u,v,w;
scanf("%d%d%d",&v,&u,&w);
add(u,v,w);
}
spfa();
int ans=INF,num;
scanf("%d",&num);
while(num--)
{
int x;
scanf("%d",&x);
if(dis[x]<ans)
ans=dis[x];
}
if(ans==INF)
printf("-1\n");
else
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: