您的位置:首页 > 其它

hdu 1718 Rank(前缀和)

2015-03-24 19:08 316 查看

Rank

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4142 Accepted Submission(s): 1607



Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the
second best mark(or is tied) his rank is 2, and so on.



Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000
and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.



Output
For each test case, output a line giving Jackson’s rank in the class.


Sample Input
20070101
20070102 100
20070101 33
20070103 22
20070106 33
0 0




Sample Output
2




Source
2007省赛集训队练习赛(2)

题目分析:记录比目标分高的人求取前缀和即可

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

typedef long long LL;

LL a,b,c,d;
LL num[107];

int main ( )
{
    while ( ~scanf ( "%lld" , &a ) )
    {    
        memset ( num , 0 , sizeof ( num ) );
        while ( ~scanf ( "%lld%lld" , &b , &c ) )
        {
            if ( b == 0 && c == 0 ) break;
            c = 100 - c;
            if ( b == a ) 
                d = c;
            num[c]++;
        }
        for ( int i = 1 ; i <= 100 ; i++ )
            num[i] = num[i-1]+num[i];
        printf ( "%lld\n" , num[d-1]+1 );
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: