您的位置:首页 > 其它

HDU 3181 Hamburger Magi(状压DP)

2015-03-24 12:32 267 查看
Problem Description

In the mysterious forest, there is a group of Magi. Most of them like to eat human beings, so they are called “The Ogre Magi”, but there is an special one whose favorite food is hamburger, having been jeered by the others as “The Hamburger Magi”.

Let’s give The Hamburger Magi a nickname “HamMagi”, HamMagi don’t only love to eat but also to make hamburgers, he makes N hamburgers, and he gives these each hamburger a value as Vi, and each will cost him Ei energy, (He can use in total M energy each day).
In addition, some hamburgers can’t be made directly, for example, HamMagi can make a “Big Mac” only if “New Orleams roasted burger combo” and “Mexican twister combo” are all already made. Of course, he will only make each kind of hamburger once within a single
day. Now he wants to know the maximal total value he can get after the whole day’s hard work, but he is too tired so this is your task now!



Input

The first line consists of an integer C(C<=50), indicating the number of test cases.

The first line of each case consists of two integers N,E(1<=N<=15,0<=E<=100) , indicating there are N kinds of hamburgers can be made and the initial energy he has.

The second line of each case contains N integers V1,V2…VN, (Vi<=1000)indicating the value of each kind of hamburger.

The third line of each case contains N integers E1,E2…EN, (Ei<=100)indicating the energy each kind of hamburger cost.

Then N lines follow, each line starts with an integer Qi, then Qi integers follow, indicating the hamburgers that making ith hamburger needs.



Output

For each line, output an integer indicating the maximum total value HamMagi can get.



Sample Input

1
4 90
243 464 307 298 
79 58 0 72
3 2 3 4
2 1 4
1 1
0




Sample Output

298



简单的状压DP;
多设一个状态s[i]表示当前i状态下还有多少E剩余来判断能不能更新。
因为优先级的问题卡了一上午。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int INF = 0x3f3f3f3f;
#define N 16
int dp[1<<N],s[1<<N];
int val[110],e[110];
int f[110];//所需状态
int c,n,E;
int main()
{
    int num,x;
    scanf("%d",&c);
    while(c--)
    {
        scanf("%d%d",&n,&E);CLEAR(f,0);
        REPF(i,1,n)  scanf("%d",&val[i]);
        REPF(i,1,n)  scanf("%d",&e[i]);
        REPF(i,1,n)
        {
            scanf("%d",&num);
            while(num--)
            {
                scanf("%d",&x);
                f[i]|=(1<<(x-1));
            }
        }
        CLEAR(dp,-1);CLEAR(s,0);
        dp[0]=0;s[0]=E;int status=(1<<n)-1;
        for(int i=0;i<=status;i++)
        {
            if(dp[i]==-1)  continue;
            for(int j=1;j<=n;j++)
            {
                if(i&(1<<(j-1))) continue;
                if((i|f[j])!=i) continue;
                int st=i|(1<<(j-1));
                if(dp[st]<dp[i]+val[j]&&s[i]>=e[j])
                {
                    dp[st]=dp[i]+val[j];
                    s[st]=s[i]-e[j];
                }
            }
        }
        int ans=0;
        for(int i=0;i<=status;i++)
            ans=max(ans,dp[i]);
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: