您的位置:首页 > 产品设计 > UI/UE

hdu 1026 Ignatius and the Princess I (bfs+记录路径)(priority_queue)

2015-03-24 12:09 435 查看
题目:http://acm.hdu.edu.cn/showproblem.php?pid=1026

[align=left]Problem Description[/align]
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

[align=left]Input[/align]
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

[align=left]Output[/align]
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

[align=left]Sample Input[/align]

5 6

.XX.1.
..X.2.
2...X.
...XX.
XXXXX.
5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX1
5 6
.XX...
..XX1.
2...X.
...XX.
XXXXX.

[align=left]Sample Output[/align]

It takes 13 seconds to reach the target position, let me show you the way.

1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)

5s:(2,2)->(2,3)

6s:(2,3)->(1,3)

7s:(1,3)->(1,4)

8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)

10s:(1,4)->(1,5)

11s:(1,5)->(2,5)
12s:(2,5)->(3,5)

13s:(3,5)->(4,5)

FINISH

It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)

3s:(1,1)->(2,1)

4s:(2,1)->(2,2)

5s:(2,2)->(2,3)
6s:(2,3)->(1,3)

7s:(1,3)->(1,4)

8s:FIGHT AT (1,4)

9s:FIGHT AT (1,4)

10s:(1,4)->(1,5)
11s:(1,5)->(2,5)

12s:(2,5)->(3,5)

13s:(3,5)->(4,5)

14s:FIGHT AT (4,5)

FINISH

God please help our poor hero.

FINISH

笔记:1.以前写bfs时都是直接使用的queue,其队顶元素为front(),使用优先队列一般需要写明以什么优先,即friend bool operator < (node a,node b)···且队顶元素为top()
   2.需要记录路径时,需要记录其前驱位置,以便输出。
   3.在输出时,直接使用递归输出就好,即从出口一直递归到入口,即只有一条路径!

#include<iostream>
#include<queue>
#include<cstdio>

using namespace std;

struct node{
int x,y;
int time;
friend bool operator < (node a,node b){//优先队列!!
return a.time > b.time;
}
};

struct M{
char data;
int prex,prey;
int time;
}map[102][102];

int n,m;
int dir[4][2]={1,0,-1,0,0,1,0,-1};

bool isInMap(int x,int y){
return x>=0&&x<n&&y>=0&&y<m;
}

int bfs(){
node cur,next;
priority_queue<node> q;
cur.x = 0;
cur.y = 0;
cur.time = 0;
map[0][0].data = 'X';
q.push(cur);
while(!q.empty()){
cur = q.top();
q.pop();
if(cur.x == n-1 && cur.y == m-1)
return cur.time;
for(int i=0;i<4;i++){
int xx = cur.x + dir[i][0];
int yy = cur.y + dir[i][1];
if(isInMap(xx,yy) && map[xx][yy].data == '.'){
next.x = xx;
next.y = yy;
next.time = cur.time+1;
map[xx][yy].prex = cur.x;
map[xx][yy].prey = cur.y;
map[xx][yy].time = 0;
map[xx][yy].data = 'X';
q.push(next);
}
else if(isInMap(xx,yy) && map[xx][yy].data!='X'){
next.x = xx;
next.y = yy;
next.time = cur.time + (map[xx][yy].data-'0') + 1;//记得加上通过时间
map[xx][yy].prex = cur.x;
map[xx][yy].prey = cur.y;
map[xx][yy].time = map[xx][yy].data-'0';
map[xx][yy].data = 'X';
q.push(next);
}
}
}
return -1;
}

void printPath(int x,int y,int time){
if(time>0){
if(map[x][y].time--){
printPath(x,y,time-1);
printf("%ds:FIGHT AT (%d,%d)\n",time--,x,y);
}
else{
printPath(map[x][y].prex,map[x][y].prey,time-1);
printf("%ds:(%d,%d)->(%d,%d)\n",time--,map[x][y].prex,map[x][y].prey,x,y);
}
}
return ;
}

int main(){
while(cin>>n>>m){
for(int i=0;i<n;i++){
getchar();
for(int j=0;j<m;j++){
scanf("%c",&map[i][j].data);
}
}
int time = bfs();
if(time>=0){
printf("It takes %d seconds to reach the target position, let me show you the way.\n",time);
printPath(n-1,m-1,time);
}
else{
printf("God please help our poor hero.\n");
}
printf("FINISH\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: