您的位置:首页 > 其它

hdu 1260 Tickets(dp)

2015-03-23 23:54 337 查看


Tickets

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1318 Accepted Submission(s): 639



Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.

A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.

Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full
of appreciation for your help.



Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

1) An integer K(1<=K<=2000) representing the total number of people;

2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;

3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.



Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.



Sample Input

2
2
20 25
40
1
8




Sample Output

08:00:40 am
08:00:08 am



题意:n组test,每组有k个人,给你每个人买票的用时,然后再给你前后两个人一起买票的用时,求全部人买完票的最小用时。

题解;dp[i][0]表示第i个人自己一个人买票,dp[i][1]表示与前一个一起买票
则有
dp[i][0]=a[i]+min(dp[i-1][0],dp[i-1][1]);
            dp[i][1]=b[i]+min(dp[i-2][0],dp[i-2][1]);

最后将最小用时装换一下就可以了。

code:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define N 2020
#define INF 1001000

using namespace std;

int n;
int a
,b
;
int dp
[2];

int main() {
int t;
cin>>t;
while(t--) {
scanf("%d",&n);
for(int i=1; i<=n; i++)
scanf("%d",&a[i]);
b[0]=INF;
for(int i=2; i<=n; i++)
scanf("%d",&b[i]);
dp[1][0]=a[1];
dp[1][1]=INF;
dp[0][0]=0;
dp[0][1]=0;
for(int i=2; i<=n; i++) {
dp[i][0]=a[i]+min(dp[i-1][0],dp[i-1][1]); dp[i][1]=b[i]+min(dp[i-2][0],dp[i-2][1]);
}
int ans=min(dp
[1],dp
[0]);
int se=ans%60;
ans/=60;
int mins=ans%60;
ans/=60;
int h=ans+8;
int flag=0;
if(h<10)printf("0%d:",h);
else if(h>=10&&h<=11)printf("%d:",h);
else {
int hh=h-12;
if(hh<10)printf("0");
printf("%d:",hh);
flag=1;
}
if(mins<10)printf("0");
printf("%d:",mins);
if(se<10)
printf("0");
printf("%d",se);
if(flag)printf(" pm\n");
else printf(" am\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: