您的位置:首页 > 其它

poj1012.Joseph(数学推论)

2015-03-23 16:43 441 查看
Joseph

Time Limit: 1 Sec Memory Limit: 64 MB Submit: 493 Solved: 311

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0


Sample Output

5
30


HINT

#include <stdio.h>

int main()
{
//freopen ("a.txt" , "r" , stdin ) ;
int people[50] = {0}, k, Joseph[14] = {0};//Joseph用于打表,不然超时
while(scanf("%d", &k) != EOF && k != 0)
{
if (Joseph[k] != 0)
{
printf("%d\n", Joseph[k]);
continue;
}
int n = 2 * k;
int m = 1;
people[0] = 0;//people[0] = 0表示编号从0开始
for (int i = 1; i <= k; i++)
{
//每次枚举完毕将剩下的人按从0到n - i编号,只要好人没有杀掉,则前面k - 1个编号是不变的
people[i] = (people[i - 1] + m - 1) % (n - i + 1);
//  printf ("[%d] = %d , " , i , people[i] ) ;
if (people[i] < k)//第k个人的编号为k - 1,所以这里是<而不是<=
{
i = 0 ;
m++;
}
}
// printf ("\n") ;
Joseph[k] = m;
printf("%d\n", m);
}
return 0;
}


View Code
走过 时间
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: