您的位置:首页 > 其它

杭电 HDU 1060 Leftmost Digit

2015-03-23 16:32 375 查看

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14198 Accepted Submission(s): 5437



Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.



Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).



Output
For each test case, you should output the leftmost digit of N^N.



Sample Input
2
3
4




Sample Output
2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


Author

Ignatius.L

 #include<iostream>
#include<cmath>
using namespace std;
int main()
{
  int  n;int T;
     cin>>T;
  while(T--)
  {
   scanf("%d",&n);
  double sum1=n*log10(double(n));
   double sum2=sum1-floor(sum1);
   printf("%d\n",int (pow(10,sum2)));
  }
  return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: