您的位置:首页 > 其它

UVA - 301 - Transportation (暴力回溯)

2015-03-23 14:40 375 查看
UVA - 301

Transportation

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description





Ruratania is just entering capitalism and is establishing new enterprising activities in many fields including transport. The transportation company TransRuratania is starting a new express train from city A
to city B with several stops in the stations on the way. The stations are successively numbered, city A station has number 0, city B station number m. The company runs an experiment in order to improve passenger transportation capacity and thus to
increase its earnings. The train has a maximum capacity n passengers. The price of the train ticket is equal to the number of stops (stations) between the starting station and the destination station (including the destination station). Before the
train starts its route from the city A, ticket orders are collected from all onroute stations. The ticket order from the station S means all reservations of tickets from S to a fixed destination station. In case the company cannot accept all orders because
of the passenger capacity limitations, its rejection policy is that it either completely accept or completely reject single orders from single stations.

Write a program which for the given list of orders from single stations on the way from A to B determines the biggest possible total earning of the TransRuratania company. The earning from one accepted order
is the product of the number of passengers included in the order and the price of their train tickets. The total earning is the sum of the earnings from all accepted orders.

Input

The input file is divided into blocks. The first line in each block contains three integers: passenger capacity n of the train, the number of the city B station and the number of ticket orders from
all stations. The next lines contain the ticket orders. Each ticket order consists of three integers: starting station, destination station, number of passengers. In one block there can be maximum 22 orders. The number of the city B station will be at most
7. The block where all three numbers in the first line are equal to zero denotes the end of the input file.

Output

The output file consists of lines corresponding to the blocks of the input file except the terminating block. Each such line contains the biggest possible total earning.

Sample Input

10 3 4
0 2 1
1 3 5
1 2 7
2 3 10
10 5 4
3 5 10
2 4 9
0 2 5
2 5 8
0 0 0


Sample Output

19
34


Source

Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Problem Solving Paradigms :: Complete Search :: Recursive
Backtracking (Medium)

Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 3. Brute Force :: Backtracking - Easy
Submit Status

思路:这题先给出三个数,分别代表火车的容量,有几个站和有几个订单,根据订单的取舍来决定最大利益

用dfs递归求解,枚举每一个订单取或不取的情况来求得最大值

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm> 
using namespace std;

const int maxn = 30;

struct node {
	int u, v, peo;
}a[maxn];

int A[maxn];//每个站最大的容量,这题里的容量也可以看做earning,递归结束时可以以之和表earning 
int ans;
int cap, B, n;

void dfs(int cur) {
	if(cur == n) {
		int sum = 0;
		for(int i = 0; i < B; i++) {
			sum += A[i];
		}
		ans = max(ans, sum);
		return;
	}
	
	int ok = 1;
	for(int i = a[cur].u; i < a[cur].v; i++)
		if(A[i] + a[cur].peo > cap) {
			ok = 0; break;
		}
	if(ok) {	//判断可不可以接受第cur个订单 
		for(int i = a[cur].u; i < a[cur].v; i++) A[i] += a[cur].peo;
		dfs(cur + 1);		//接受第cur个订单,然后往后走 
		for(int i = a[cur].u; i < a[cur].v; i++) A[i] -= a[cur].peo;
	}
	dfs(cur + 1);		//不接受第cur个订单,然后往后走 
}

int main() {
	while(scanf("%d %d %d", &cap, &B, &n), cap || B || n) {
		ans = 0;
		memset(A, 0, sizeof(A));
		
		for(int i = 0; i < n; i++) {
			scanf("%d %d %d", &a[i].u, &a[i].v, &a[i].peo);
		}
		
		dfs(0);
		printf("%d\n", ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: