您的位置:首页 > 其它

poj 1523 SPF(无向图求关节点)

2015-03-22 22:15 495 查看
SPF

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 6609Accepted: 3019
Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from
communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected
network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.



Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers
will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when
that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input
1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output
Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source

Greater New York 2000
在用程序实现前面所述的求关节点的算法时,需要解决以下几个问题:

1) 如何判断顶点v 是顶点u 的祖先结点;

2) 如何判断边(v, u)是回边;

3) 如何判断顶点v 是顶点u 的儿子结点。

这3 个问题都是在深度优先搜索函数dfs 中解决的。从顶点u 出发进行DFS 搜索时,要判断

其他每个顶点v 是否跟u 是否邻接、是否未访问过。如果v 跟u 邻接,则在生成树中就是2 种情

况:

① 如果顶点v 是顶点u 的邻接顶点,且此时v 还未访问过,则v 是u 的儿子结点;

② 如果顶点v 是顶点u 的邻接顶点,且此时v 已经访问过了,则v 是u 的祖先结点,且(v, u)

就是一条回边。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 10010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

void read(int &x)
{
    char ch;
    x=0;
    while(ch=getchar(),ch!=' '&&ch!='\n')
    {
        x=x*10+ch-'0';
    }
}

int Edge[1010][1010];//邻接矩阵 存储边
int vis[1010];
int nodes;//顶点数目
int tmpdfn;//dfs过程中记录当前深度优先搜索序数
int dfn[1010];//每个顶点的dfs的值
int low[1010];//每个顶点的low值  根据该值来判断是否是关节点
int son;//根节点的子女结点的个数(如果大于2  则根节点是关节点)
int subnets[1010];//记录每个节点(去掉该节点后)的连通分量个数

void dfs(int u)
{
    for(int v=1;v<=nodes;v++)
    {
        //v跟u邻接
        //1 v是u的祖先结点 这样(v,u)就是一条回边  2v是u的儿子节点
        if(Edge[u][v])
        {
            if(!vis[v])
            {
                vis[v]=1;
                tmpdfn++;
                dfn[v]=low[v]=tmpdfn;
                dfs(v);//dfs(v)执行完毕后 low[v]值已求出
                //回退的时候 计算顶点u的low值
                low[u]=min(low[u],low[v]);
                if(low[v]>=dfn[u])
                {
                    if(u!=1)  subnets[u]++;
                    if(u==1)  son++;
                }
            }
            //此前v已经访问过了  v是u的祖先结点
            else low[u]=min(low[u],dfn[v]);
        }
    }
}

void init()
{
    low[1]=dfn[1]=1;
    tmpdfn=1;
    son=0;
    MEM(vis,0);
    vis[1]=1;
    MEM(subnets,0);
}

int main()
{
//    fread;
    int u,v;
    bool flag;
    int cs=1;
    while(1)
    {
        scanf("%d",&u);
        if(u==0)  break;
        MEM(Edge,0);
        nodes=0;
        scanf("%d",&v);
        if(u>nodes)  nodes=u;
        if(v>nodes)  nodes=v;
        Edge[u][v]=Edge[v][u]=1;
        while(1)
        {
            scanf("%d",&u);
            if(u==0)  break;
            scanf("%d",&v);
            if(u>nodes)  nodes=u;
            if(v>nodes)  nodes=v;
            Edge[u][v]=Edge[v][u]=1;
        }
        if(cs>1)  puts("");
        printf("Network #%d\n",cs++);
        init();
        dfs(1);
        if(son>1)  subnets[1]=son-1;
        flag=0;
        for(int i=1;i<=nodes;i++)
        {
            if(subnets[i])
            {
                flag=1;
                printf("  SPF node %d leaves %d subnets\n",i,subnets[i]+1);
            }
        }
        if(!flag)  printf("  No SPF nodes\n");
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: