您的位置:首页 > 编程语言 > Go语言

hdoj 2391 Filthy Rich (动态规划)

2015-03-22 17:38 232 查看

Problem I

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 84   Accepted Submission(s) : 28

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout
the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the
same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so?

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end
up in the lower right corner.

Input

The input starts with a line containing a single integer, the number of test cases.

Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field.
The amount of gold never negative.

The maximum amount of gold will always fit in an int.

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case.
Finish each test case with an empty line.此处周赛没看到直接PE了一次

Sample Input

1
3 4
1 10 8 8
0 0 1 8
0 27 0 4


Sample Output

Scenario #1:
42


/*

典型的动态规划

*/

#include<cstdio>

#include<cstring>

#include<cmath>

#include<cstdlib>

#include<algorithm>

using namespace std;

int map[1001][1001];

int dp[1001][1001];

int Max(int a,int b,int c)

{
return max(a,max(b,c));

}

int main()

{
int t,ca=1;
scanf("%d",&t);
while(t--)
{
 int r,c,i,j;
 scanf("%d%d",&r,&c);
 for(i=1;i<=r;i++)
   for(j=1;j<=c;j++)
     scanf("%d",&map[i][j]);

 memset(dp,0,sizeof(dp));
 for(i=1;i<=r;i++)
   for(j=1;j<=c;j++)
     dp[i][j]+=Max(dp[i-1][j],dp[i-1][j-1],dp[i][j-1])+map[i][j];

     printf("Scenario #%d:\n%d\n\n",ca++,dp[r][c]);//注意格式
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息