您的位置:首页 > Web前端

A Bug's Life-HDU-1829

2015-03-22 15:29 302 查看
题目地址:hdu-1829

本题是考察并查集的运用。

**题意:有k对编号为1~n的果蝇交配了,

给你数据后让你判断是否有同性恋。**

Problem Description

Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2

3 3

1 2

2 3

1 3

4 2

1 2

3 4

Sample Output

Scenario #1:

Suspicious bugs found!

Scenario #2:

No suspicious bugs found!

———————————————–

AC代码如下:



//题意:有k对编号为1~n的果蝇交配了,
//给你数据后让你判断是否有同性恋。
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn=52014;
int t,n,k,par[maxn];
int fun(int x)//寻找根节点
{
    return par[x]==x?x:par[x]=fun(par[x]);
}
void unite(int x,int y)//将两个结点的根结点找出并合并在在一起。
{
    int a=fun(x),b=fun(y);
    if(a!=b)
        par[a]=b;
}
bool same(int x,int y)//判断两个结点是否是在同一组内。
{
    return fun(x)==fun(y);
}
int main()
{
    scanf("%d",&t);
    for(int tt=1; tt<=t; tt++)
    {
        bool exist=false;
        int x,y;
        scanf("%d%d",&n,&k);
        for(int i=1; i<=2*n; i++)
            par[i]=i;
        for(int i=0; i<k; i++)
        {
            scanf("%d%d",&x,&y);
            if(!same(x,y))
            //如果x和y不是同性恋的话,如果x是雄的话,那么y+n一定也是雄。
            {//如果x+n是雌的话,那么y一定也是雌。
                unite(x,y+n);
                unite(x+n,y);
            }
            else
                exist=true;//果蝇之间存在同性恋。
        }
        printf("Scenario #%d:\n",tt);
        if(exist)
            printf("Suspicious bugs found!\n\n");
        else
            printf("No suspicious bugs found!\n\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: