您的位置:首页 > 其它

hdoj 1690 Bus System 【最短路径】

2015-03-22 10:04 351 查看

Bus System

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7138 Accepted Submission(s): 1847



Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.

The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?

To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.

Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.

Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start
point and the destination.

In all of the questions, the start point will be different from the destination.

For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

Sample Input
2
1 2 3 4 1 3 5 7
4 2
1
2
3
4
1 4
4 1
1 2 3 4 1 3 5 7
4 1
1
2
3
10
1 4


Sample Output
Case 1:
The minimum cost between station 1 and station 4 is 3.
The minimum cost between station 4 and station 1 is 3.
Case 2:
Station 1 and station 4 are not attainable.


floyd: 注意INF要开大点!!!

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#define INF 0x3f3f3f3f3f3f
#define max 500+10
__int64 map[max][max],sta[max];
void floyd(__int64 n)
{
    int k,i,j;
    for(k=1;k<=n;k++)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(map[i][j]>map[i][k]+map[k][j])
                map[i][j]=map[i][k]+map[k][j];
            }
        }
    }
}
int main()
{
    __int64 cost[max],dis[max];
    __int64 t,n,m,i,j;
    __int64 Sta,d,k=1;
    __int64 start,end;
    scanf("%I64d",&t);
    while(t--)
    {
        for(i=1;i<=4;i++)
        scanf("%I64d",&dis[i]);
        for(i=1;i<=4;i++)
        scanf("%I64d",&cost[i]);
        scanf("%I64d%I64d",&n,&m);
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(i==j)
                map[i][j]=0;
                else
                map[i][j]=INF;
            }
        }
        for(i=1;i<=n;i++)
        scanf("%I64d",&sta[i]);
        for(i=1;i<=n;i++)
        {
            for(j=i+1;j<=n;j++)
            {
                d=abs(sta[j]-sta[i]);
                if(d>0&&d<=dis[1])
                d=cost[1];
                else if(d>dis[1]&&d<=dis[2])
                d=cost[2];
                else if(d>dis[2]&&d<=dis[3])
                d=cost[3];
                else if(d>dis[3]&&d<=dis[4])
                d=cost[4];
                else
                d=INF;
                if(map[i][j]>d)
                map[i][j]=map[j][i]=d;
            }
        }
        floyd(n);
        printf("Case %I64d:\n",k++);
        for(i=0;i<m;i++)
        {
            scanf("%I64d%I64d",&start,&end);
            if(map[start][end]==INF)
            printf("Station %I64d and station %I64d are not attainable.\n",start,end);
            else
            printf("The minimum cost between station %I64d and station %I64d is %I64d.\n",start,end,map[start][end]);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: