您的位置:首页 > 其它

杭电1003 Max Sum

2015-03-21 21:41 543 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1003



Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.



Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).



Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.



Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5




Sample Output

Case 1:
14 1 4

Case 2:
7 1 6




#include<stdio.h>
int main()
{
	int sum,max,i;
	int test,n;
	int a;
	int num=0;
	scanf("%d",&test);	
	while(test--)
	{		
		scanf("%d",&n);				
		max=-100000;sum=0;
		int left,right;		
		int temp=1;
		for(i=1;i<=n;++i)
		{		
			scanf("%d",&a);			
			sum+=a;
			if(sum>max)
			{
				max=sum;
				left=temp;//改变左边的 (从哪项开始加的) 
				right=i;
			}	
			if(sum<0)
			{
				sum=0;  //让sum从i+1开始加 
				temp=i+1;//sum<0说明a肯定小于零				
			}		
		}
		printf("Case %d:\n",++num);
		printf("%d %d %d\n",max,left,right);
		if(test!=0) printf("\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: