您的位置:首页 > 大数据 > 人工智能

HDU 1702--ACboy needs your help again!【STL】

2015-03-21 17:06 746 查看

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3866 Accepted Submission(s): 1958



Problem Description
ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!


Input
The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.


Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.


Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT




Sample Output
1
2
2
1
1
2
None
2
3




开始用STL中栈,队列写的,水题。

#include <iostream>
#include <algorithm>
#include <stack>
#include <queue>
using namespace std;

int main (){
    int t,i;
    cin>>t;
    while(t--){
        int n,x;
        string str;
        string mark;
        cin>>n>>str;
        if(str.compare("FIFO")==0){
            queue<int>q1;
            while(n--){
                cin>>mark;
                if(mark.compare("IN")==0){
                    cin>>x;
                    q1.push(x);
                }
                else if(mark.compare("OUT")==0){
                    if(q1.empty())
                        cout<<"None"<<endl;
                    else{
                        cout<<q1.front()<<endl;
                        q1.pop();
                    }
                }
            }
        }
        else if(str.compare("FILO")==0){
            stack<int>q2;
            while(n--){
                cin>>mark;
                if(mark.compare("IN")==0){
                    cin>>x;
                    q2.push(x);
                }
                else if(mark.compare("OUT")==0){
                    if(q2.empty())
                        cout<<"None"<<endl;
                    else{
                        cout<<q2.top()<<endl;
                        q2.pop();
                    }
                }
            }
        }
    }
    return 0;
}


后来用数组模拟写的,错了好几次,看来不能忽略基础啊

#include <stdio.h>
#include <string.h>

int main (){
    int t,i;
    scanf("%d",&t);
    while(t--){
        int n,x;
        char str[10];
        char mark[10];
        int a[100000];
        scanf("%d",&n);
        scanf("%s",&str);
        if(strcmp(str,"FIFO")==0){//队列
            int j,j1;
            j=j1=0;//j为进队列数,j1为出队列数
            while(n--){
                scanf("%s",mark);
                if(strcmp(mark,"IN")==0){
                    scanf("%d",&x);
                    a[j++]=x;
                }
                else{
                    if(j1>=j)
                        printf("None\n");
                    else
                        printf("%d\n",a[j1++]);
                }
            }
        }
        else {//栈
            int j;
            j=0;
            while(n--){
                scanf("%s",mark);
                if(strcmp(mark,"IN")==0){
                    scanf("%d",&x);
                    a[j++]=x;
                }
                else{
                    if(j<1)
                        printf("None\n");
                    else
                        printf("%d\n",a[--j]);
                }
            }
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: