您的位置:首页 > 产品设计 > UI/UE

ACM--steps--dyx--1.2.4--Buildings

2015-03-21 10:45 330 查看

Buildings

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2432 Accepted Submission(s): 1728
Problem Description

We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.



Input

Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands
for green.

Output

Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.

Sample Input

2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0


Sample Output

2
5


Source

2008 HZNU Programming Contest

Recommend

lcy

#include<iostream>
using namespace std;
int main()
{
int t;//表示测试数据。
int dyx[109][109];
while(cin>>t)
{
while(t--)
{
int sum=0;
int n,m;
cin>>n>>m;//表示地图的行列。
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
cin>>dyx[i][j];
if(dyx[i][j]==1)
sum++;
}
}
cout<<sum<<endl;
}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: