您的位置:首页 > 其它

hdu1029 Ignatius and the Princess IV

2015-03-21 00:45 435 查看


Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32767 K (Java/Others)

Total Submission(s): 19153 Accepted Submission(s): 7764



Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?



Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is
terminated by the end of file.



Output

For each test case, you have to output only one line which contains the special number you have found.



Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1




Sample Output

3
5
1




Author

Ignatius.L



Recommend

We have carefully selected several similar problems for you: 1074 1028 1171 1280 1024



#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 1000010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;
typedef long long ll;

const int INF = 1000010;

using namespace std;

int a
;
int n;

int main() {
    while(cin>>n) {
        for(int i=0; i<n; i++) {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        int Min=INF,time=1,it=0;
        int t=(n+1)/2;
        for(int i=1; i<n; i++) {
            if(a[i]==a[i-1])time++;
            else if(abs(time-t)<Min) {
                Min=abs(time-t);
                it=i-1;
                time=1;
            }
        }
        if(a[n-1]==a[n-2]&&abs(time-t)<Min)it=n-1;
        cout<<a[it]<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: