您的位置:首页 > 其它

UVA - 10474 - Where is the Marble? (基数排序)

2015-03-20 21:48 387 查看
UVA - 10474

Where is the Marble?

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description





Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written
on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with
maximum points wins. Today it's your chance to play as Raju. Being the smart kid, you'd be taking the favor of a computer. But don't underestimate Meena, she had written a program to keep track how much time you're taking to give all the answers. So now you
have to write a program, which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the
number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines
will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.
Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

`x found at y', if the first marble with number x was found at position y. Positions are numbered 1,
2,..., N.
`x not found', if the marble with number x is not present.

Look at the output for sample input for details.

Sample Input

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0


Sample Output

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3


Problem-setter: Monirul Hasan Tomal, Southeast University

Source

Root :: Prominent Problemsetters :: Monirul Hasan

Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 1. Elementary Problem Solving :: Sorting/Searching

Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 3. Problem Solving Paradigms :: Divide
and Conquer

Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Problem Solving Paradigms :: Divide
and Conquer -Binary Search

Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 3. Brute Force :: Backtracking - Easy

Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Problem Solving Paradigms :: Divide and Conquer :: Binary
Search

Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 5. C++ and STL :: Examples
Submit Status

思路:就是给出一组数据,这组数据按从小到大排列,然后再查询一个数是否在数组中,在的话输出排在第几

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

int num[10005];

int main() {
	int m, n;
	int cas = 1;
	while(scanf("%d %d", &m, &n), m || n) {
		printf("CASE# %d:\n", cas++);
		memset(num, 0, sizeof(num));
		for(int i = 0; i < m; i++) {
			int t;
			scanf("%d", &t);
			num[t]++;
		}
		for(int i = 0; i < n; i++) {
			int t;
			scanf("%d", &t);
			if(num[t] == 0) {
				printf("%d not found\n", t);
			}
			else
			{
				int ans = 0;
				for(int i = 0; i < t; i++) ans += num[i];
				printf("%d found at %d\n", t, ans + 1);
			}
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: