您的位置:首页 > 其它

hdu 1455 Sticks DFS 又是一个花样剪枝 ,累觉不爱

2015-03-20 09:28 330 查看

Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6750 Accepted Submission(s): 1967



Problem Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were
originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.



Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the
file contains zero.



Output
The output file contains the smallest possible length of original sticks, one per line.



Sample Input
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0




Sample Output
6
5


这题TLE了N次,也WA了很多次,算是长教训了
贴两份代码吧
别问我为什么,有代码人性!

代码:
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std ;

int n , d[70] , t;
bool visited[70] , notPrime[65*55];

bool cmp(const int a , const int b)
{
	return a>b ;
}

bool dfs(int len , int sum , int c , int pos)
{
	if(c == t)
	{
		return true ;
	}
	else if(len == sum)
	{
		if(dfs(len,0,c+1,0))
		{
			return true ;
		}
	}
	else
	{
		for(int i = pos ; i < n ; ++i)
		{
			if(!visited[i])
			{
				if(sum+d[i]>len)
				{
					continue ;
				}
				visited[i] = true ;
				if(dfs(len,sum+d[i],c,i+1))
				{
					return true ;
				}
				visited[i] = false ;
				//这一步剪枝很重要 ,没有可能超时 
				if(sum == 0)
				{
					return false ;
				}
				//如果下一个 长度与当前相等,那无需再次重复搜索 
				while(d[i] == d[i+1])	++i ;
			}
		}
	}
	return false ;
}

int main()
{
	while(~scanf("%d",&n) && n)
	{
		int sum = 0 ;
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d",&d[i]) ;
			sum += d[i] ;
		}
		bool flag = false ;
		sort(d,d+n,cmp) ;
		for(int i =  d[0]; i <= sum/2 ; ++i)
		{
			if(sum%i == 0)		//剪枝,当且仅当sum能整除i时,才有可能 
			{
				t = sum/i ;
				memset(visited,false,sizeof(visited)) ;
				if(dfs(i,0,1,0))
				{
					printf("%d\n",i) ;
					flag = true ;
					break ;
				}
			}
		}
		if(!flag)
		{
			printf("%d\n",sum) ;
		}
	}
	return 0 ;
}


代码:
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std ;

int n , d[70] ;
bool visited[70] , notPrime[65*55];

bool cmp(const int a , const int b)
{
	return a>b ;
}

bool dfs(int len , int sum , int c , int pos)
{
	if(c == n)
	{
		return true ;
	}
	else if(len == sum)
	{
		if(dfs(len,0,c,0))
		{
			return true ;
		}
	}
	else
	{
		for(int i = pos ; i < n ; ++i)
		{
			if(!visited[i])
			{
				if(sum+d[i]>len)
				{
					continue ;
				}
				visited[i] = true ;
				if(dfs(len,sum+d[i],c+1,i+1))
				{
					return true ;
				}
				visited[i] = false ;
				//这一步剪枝很重要 ,没有可能超时 
				if(sum == 0)
				{
					return false ;
				}
				//如果下一个 长度与当前相等,那无需再次重复搜索 
				while(d[i] == d[i+1])	++i ;
			}
		}
	}
	return false ;
}

int main()
{
	while(~scanf("%d",&n) && n)
	{
		int sum = 0 ;
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d",&d[i]) ;
			sum += d[i] ;
		}
		bool flag = false ;
		sort(d,d+n,cmp) ;
		for(int i =  d[0]; i <= sum/2 ; ++i)
		{
			if(sum%i == 0)		//剪枝,当且仅当sum能整除i时,才有可能 
			{
				memset(visited,false,sizeof(visited)) ;
				if(dfs(i,0,1,0))
				{
					printf("%d\n",i) ;
					flag = true ;
					break ;
				}
			}
		}
		if(!flag)
		{
			printf("%d\n",sum) ;
		}
	}
	return 0 ;
}


与君共勉
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: