您的位置:首页 > 其它

FatMouse and Cheese (hdu 1078 记忆化搜索)

2015-03-19 11:49 411 查看


FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5463 Accepted Submission(s): 2227



Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole.
Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.



Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1's.



Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.



Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1




Sample Output

37




Source

Zhejiang University Training Contest 2001



Recommend

We have carefully selected several similar problems for you: 1080 1074 1024 1081 1025



题意:给出n*n的数字矩阵,从(0,0)出发,走的下一步格子上的数要大于当前格子上的数,并且每次可以沿直线前进最多k个位置,也就是每次有4*k个选择,问最后所有数之和的最大值。

思路:记忆化搜索。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 105
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

int dir[4][2]={0,1,1,0,0,-1,-1,0};
int mp[maxn][maxn];
int sum[maxn][maxn];
int n,k;

bool Isok(int x,int y)
{
    if (x>=0&&x<n&&y>=0&&y<n) return true;
    return false;
}

int dfs(int x,int y)
{
    if (sum[x][y]) return sum[x][y];        //直接返回
    int maxx=0;
    int i,j;
    FRE(i,1,k)
    {
        FRL(j,0,4)
        {
            int dx=x+dir[j][0]*i;
            int dy=y+dir[j][1]*i;
            if (Isok(dx,dy)&&mp[x][y]<mp[dx][dy])
            {
                maxx=max(maxx,dfs(dx,dy));
            }
        }
    }
    sum[x][y]=maxx+mp[x][y];    //把从(x,y)处出发的最优答案记录下来,下次再遇到(x,y)时直接返回这个值
    return sum[x][y];
}

int main()
{
    int i,j;
    while (sff(n,k))
    {
        if (n==-1&&k==-1) break;
        FRL(i,0,n)
        FRL(j,0,n)
        sf(mp[i][j]);
        mem(sum,0);
        pf("%d\n",dfs(0,0));
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: