您的位置:首页 > 其它

Sicily 1363. Semi-prime H-numbers

2015-03-18 22:30 543 查看


1363. Semi-prime H-numbers


Constraints

Time Limit: 3 secs, Memory Limit: 32 MB


Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are theonly numbers. The H-numbers are
closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the
unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers areH-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different.
In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.


Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.


Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.


Sample Input


21 
85
789
0



Sample Output


21 0
85 5
789 62

// Problem#: 1363
// Submission#: 3305310
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/ // All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <iostream>
#include <vector>
#include <algorithm>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <string>
using namespace std;

const int MAX_H = 1000005;

int H[MAX_H];
int num[MAX_H];

int main() {

    std::cout.sync_with_stdio(false);
    
    for (int i = 5; i < 1000; i += 4)
        for (int j = i; j * i < MAX_H; j += 4)
            H[i * j] = H[i] + H[j] + 1;

    for (int i = 25; i < MAX_H; i++) num[i] = (H[i] == 1) + num[i - 1];

    while (1) {
        int temp;
        cin >> temp;
        if (temp == 0) break;
        cout << temp << " " << num[temp] << endl;
    }

    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: