您的位置:首页 > 编程语言 > C语言/C++

C语言排序(13)___众数问题(Hdu 1029)

2015-03-18 22:04 344 查看
Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains
the N integers. The input is terminated by the end of file.

Output

For each test case, you have to output only one line which contains the special number you have found.

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1


Sample Output

3
5
1


题意:输入一排数,这排数满足有一个数至少出现了n/2+1次.然后输出这个数.

map的应用.

#include<iostream>
#include<map>
using namespace std;
int main(void)
{
int ans,n,b;
while(cin>>n)
{
map<int,int>a;
for(int i=0;i<n;i++)
{
cin>>b;//用cin就超时了,超1000ms(换成scanf就375ms,,,天哪,差别有这么大么?)
a[b]++;
if(a[b]==(n+1)/2)
{
ans=b;
}
}
cout<<ans<<endl;
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: