您的位置:首页 > 其它

zoj1003-Max Sum (最大连续子序列之和)

2015-03-17 22:54 302 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 161361 Accepted Submission(s): 37794


[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

[align=left]Sample Input[/align]

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

[align=left]Sample Output[/align]

Case 1: 14 1 4

Case 2: 7 1 6

代码:

#include <fstream>
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>

using namespace std;

#define EPS 1e-10
#define ll long long
#define INF 0x7fffffff

int main()
{
//freopen("D:\\input.in","r",stdin);
//freopen("D:\\output.out","w",stdout);
int T,n,ans,tn,l,r,al,ar,t;
scanf("%d",&T);
for(int tt=1;tt<=T;tt++){
scanf("%d",&n);
ans=tn=-INF;
for(int i=1;i<=n;i++){
scanf("%d",&t);
if(tn<0){
l=r=i;
tn=t;
}else{
tn+=t;
r=i;
}
if(tn>ans){
al=l;
ar=r;
ans=tn;
}
}
printf("Case %d:\n%d %d %d\n",tt,ans,al,ar);
if(tt!=T)   puts("");
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: