您的位置:首页 > 其它

1058. A+B in Hogwarts (20)

2015-03-16 13:28 344 查看


1058. A+B in Hogwarts (20)

时间限制

50 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to
compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27

Sample Output:
14.1.28

#include<iostream>
#include<stdio.h>

using namespace std;

#define LLd long long int

int main(){
LLd g1, g2;
LLd s1, s2;
LLd k1, k2;
LLd g, s, k;
scanf("%lld.%lld.%lld %lld.%lld.%lld", &g1, &s1, &k1, &g2, &s2, &k2);
g = g1+g2;
s = s1+s2;
k = k1+k2;
int sDeal = k/29;
k = k%29;
s = s+sDeal;
int gDeal = s/17;
s = s%17;
g = g+gDeal;
printf("%lld.%lld.%lld", g, s, k);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: