您的位置:首页 > 其它

POJ 2406--Power Strings【KMP】

2015-03-16 09:51 330 查看
Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 34842Accepted: 14406
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3


#include <cstdio>
#include <cstring>

char s[1000005];
int next[1000005];

void getnext(){
    int j=0,k=-1;
    int len=strlen(s);
    next[0]=-1;
    while(j<len){
        if(k==-1 || s[k]==s[j]){
            ++j;
            ++k;
            next[j]=k;
        }
        else k=next[k];
    }
    return ;
}

int main (){
    while(scanf("%s",s)!=EOF){
        if(s[0]=='.')
            break;
        getnext();
        int len=strlen(s);
        //for(int i=0;i<=len;++i)
        //    printf("%d ",next[i]);
        // printf("\n");
        int k=len-next[len];
        if(len%k==0) printf("%d\n",len/k);
        else
            printf("1\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: