您的位置:首页 > 其它

HDU 1686--Oulipo【KMP】

2015-03-16 07:43 363 查看

Oulipo

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5779 Accepted Submission(s): 2329



Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.



Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.



Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.



Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
***ERDXIVYERDIAN




Sample Output
1
3
0




POJ上的3461 ,又水了一遍

#include <cstdio>
#include <cstring>

char s1[1000010];
char s2[1000010];
int next[1000010];

void getnext(){
    int k=-1,j=0;
    int len=strlen(s1);
    next[0]=-1;
    while(j<len){
        if(k==-1 || s1[j]==s1[k]){
        ++j;
        ++k;
        next[j]=k;
        }
        else k=next[k];
    }
    return ;
}

int kmp(){
    int i,j;
    i=j=0;
    int ans=0;
    int l=strlen(s2);
    getnext();
    while(i<l){
        if(j==-1 || s1[j]==s2[i]){
            ++i;
            ++j;
        }
        else j=next[j];
        int len=strlen(s1);
        if(j==len){
            ans++;
            j=next[j];
        }
    }
    return ans;
}
int main (){
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%s%s",s1,s2);
		printf("%d\n",kmp());
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: