您的位置:首页 > 其它

zhx's contest (矩阵快速幂 + 数学推论)

2015-03-15 19:49 267 查看

zhx's contest

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 851 Accepted Submission(s): 282

[align=left]Problem Description[/align]
As one of the most powerful brushes, zhx is required to give his juniors n problems. zhx thinks the ith problem's difficulty is i. He wants to arrange these problems in a beautiful way. zhx defines a sequence {ai} beautiful if there is an i that matches two rules below: 1: a1..ai are monotone decreasing or monotone increasing. 2: ai..an are monotone decreasing or monotone increasing. He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful. zhx knows that the answer may be very huge, and you only need to tell him the answer module p.

[align=left]Input[/align]
Multiply test cases(less than 1000). Seek EOF as the end of the file. For each case, there are two integers n and p separated by a space in a line. (1≤n,p≤1018)

[align=left]Output[/align]
For each test case, output a single line indicating the answer.

[align=left]Sample Input[/align]

2 233
3 5

[align=left]Sample Output[/align]

2
1

Hint

In the first case, both sequence {1, 2} and {2, 1} are legal.
In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1

[align=left]Source[/align]
BestCoder Round #33

#include<stdio.h>
typedef long long ll ;
ll n , mod ;

ll mut (ll a , ll b)
{
ll ans = 0 ;
while (b) {
if (b & 1) {
ans = (ans + a) % mod ;
}
a = (a + a ) % mod ;
b >>= 1 ;
}
return ans % mod ;
}

void mgml (ll a , ll b)
{
ll ans = 1 ;
while (b) {
if (b & 1) {
ans = mut (ans , a ) ;
}
b >>= 1 ;
a = mut ( a , a ) ;
}
ans -= 2 ;
ans %= mod ;
ans += mod ;
ans %= mod ;
printf ("%I64d\n" , ans ) ;
}

int main ()
{
//freopen ("a.txt" , "r" , stdin ) ;
while (~ scanf ("%I64d%I64d" , &n , &mod)) {
if (n == 1) {
printf ("%I64d\n" , 1LL % mod ) ;
continue ;
}
mgml (2 , n ) ;
}
return 0 ;
}


View Code
这道题到处是坑,推出2^n - 2照样进坑;
首先要防止n = 1 , p = 1 这种情况;

然后要防止ans - 2 < 0;

然后 是 快速幂 的内部优化,让人耳目一新啊
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: