您的位置:首页 > 其它

nyoj.204 Coin Test【水题】 2015/03/15

2015-03-15 16:33 190 查看


Coin Test

时间限制:3000 ms | 内存限制:65535 KB
难度:1

描述

As is known to all,if you throw a coin up and let it droped on the desk there are usually three results. Yes,just believe what I say ~it can be the right side or the other side or standing on the desk, If you don't believe this,just try In the past there were
some famous mathematicians working on this .They repeat the throwing job once again. But jacmy is a lazy boy.He is busy with dating or playing games.He have no time to throw a single coin for 100000 times. Here comes his idea,He just go bank and exchange thousands
of dollars into coins and then throw then on the desk only once. The only job left for him is to count the number of coins with three conditions.

He will show you the coins on the desk to you one by one. Please tell him the possiblility of the coin on the right side as a fractional number if the possiblity between the result and 0.5 is no larger than 0.003. BE CAREFUL that even 1/2,50/100,33/66 are equal
only 1/2 is accepted ! if the difference between the result and 0.5 is larger than 0.003,Please tell him "Fail".Or if you see one coin standing on the desk,just say "Bingo" any way.

输入Three will be two line as input.

The first line is a number N(1<N<65536)

telling you the number of coins on the desk.

The second line is the result with N litters.The letter are "U","D",or "S","U" means the coin is on the right side. "D" means the coin is on the other side ."S" means standing on the desk.
输出If test successeded,just output the possibility of the coin on the right side.If the test failed please output "Fail",If there is one or more"S",please output "Bingo"
样例输入
6
UUUDDD


样例输出
1/2


#include<stdio.h>
#include<string.h>
#include<math.h>
int gcd( int a,int b ){
return b?gcd(b,a%b):a;
}
int main(){
int n,num,i,m;
double sum;
char s[70000];
while(scanf("%d",&n)!=EOF){
getchar();
for( i = 0 ; i < n ; ++i )
scanf("%c",&s[i]);
if( strstr(s,"S") ){
printf("Bingo\n");
continue;
}
num = 0 ;
for( i = 0 ; i < n ; ++i ){
if( s[i] == 'U' )
num++;
}
sum = 1.0 * num / n;
if( fabs(sum-0.5) > 0.003 ){
printf("Fail\n");
continue;
}
m = gcd(num,n);
printf("%d/%d\n",num/m,n/m);
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: