您的位置:首页 > 其它

hdoj 1019 Least Common Multiple

2015-03-15 13:18 302 查看

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35323 Accepted Submission(s): 13269



Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where
m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output
105
10296


水。。。。

#include<stdio.h>
#include<algorithm> 
#define max 1000+10
using namespace std;
int a[max];
int n;
void lcm(int n,int m)
{
    int i,j,exist;
    for(i=m;;i+=m)
    {
        exist=0;
        for(j=0;j<n;j++)
        {
            if(i%a[j]==0) exist++;
            else
            break;
        }
        if(exist==n)
        {
            printf("%d\n",i);
            break;
        }
    }
}
int main()
{
    int t,i,j,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        sort(a,a+n);
        m=a[n-1];
        lcm(n,m);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: