您的位置:首页 > 其它

HDU 5187 zhx's contest(防爆__int64 )

2015-03-14 23:14 295 查看
Problem Description
As one of the most powerful brushes, zhx is required to give his juniors
n
problems.

zhx thinks the ith
problem's difficulty is i.
He wants to arrange these problems in a beautiful way.

zhx defines a sequence {ai}
beautiful if there is an i
that matches two rules below:

1: a1..ai
are monotone decreasing or monotone increasing.

2: ai..an
are monotone decreasing or monotone increasing.

He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.

zhx knows that the answer may be very huge, and you only need to tell him the answer module
p.


Input
Multiply test cases(less than
1000).
Seek EOF
as the end of the file.

For each case, there are two integers n
and p
separated by a space in a line. (1≤n,p≤1018)


Output
For each test case, output a single line indicating the answer.



Sample Input
2 233
3 5




Sample Output
2
1


思路:枚举 减 减 ; 减 加 ; 加 减 加 加 一共 2^(n-1)*2-2

1 2^(n-1) -2 2^(n-1) -2 1

//  2^n-2

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 1001

ll n,mod;

ll fdd(ll x,ll m)   //计算  x*m 居然不能直接算,否者会爆__int64 
{
	ll ans=0;
	while(m)
	{
		if(m&1) ans=(ans+x)%mod;
		x=(x+x)%mod;
		m>>=1;
	}
   return ans;
}

ll pow_(ll n,ll m)
{
     ll ans=1;

     while(m)
	 {
	 	 if(m&1) ans=fdd(ans,n);  //计算 ans*n
	 	 n=fdd(n,n);              //计算 n*n
	 	 m>>=1;
	 }
      return (ans-2+mod)%mod;
}

int main()
{
	while(~scanf("%I64d%I64d",&n,&mod))
	{
		  ll ans=2;
		  if(n==1)
		  {
            ans=n%mod;
		  	pf("%I64d\n",ans);
		  	continue;
		  }
		  printf("%I64d\n",pow_(ans,n));
	}

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: