您的位置:首页 > 大数据 > 人工智能

HDU - 1789 Doing Homework again(贪心)

2015-03-13 15:50 375 查看
Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce
his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4


Sample Output

0
3
5


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct node{
int deadlines;
int score;
bool vist;
}homework[1005];

bool vis[1005];
int N;

bool cmp(node a,node b){
return a.score > b.score;
}

void init(){
memset(vis,false,sizeof(vis));
cin>>N;
for(int i = 0 ; i < N; i++)cin>>homework[i].deadlines;
for(int i = 0 ; i < N; i++)cin>>homework[i].score,homework[i].vist = false;
sort(homework,homework+N,cmp);
}

int main(){
int T;
cin>>T;
while(T--){
init();
for(int i = 0 ; i < N; i++)
for(int j = homework[i].deadlines; j > 0; j--)
if(!vis[j]&&!homework[i].vist){
vis[j] = true;
homework[i].vist = true;
}
int sum = 0;
for(int i = 0 ; i < N ; i ++)
if(!homework[i].vist) sum+=homework[i].score;
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: