您的位置:首页 > 产品设计 > UI/UE

hdoj 1509 Windows Message Queue 优先队列

2015-03-12 22:03 274 查看



Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4049 Accepted Submission(s): 1591



Problem Description

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will
do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message
from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by.
There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET


Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!


题目大意是windows的信息队列是按照优先级执行的,输入PUT时输入一行信息,包括一个字符串和两个整数,第一个整数是元素,第二个是优先级,输入GET指令时按照优先级的从低到高输出信息,当两个优先级相同时按照输入的顺序输出。练习使用优先队列。

注意:当两个优先级相同时按照输入的顺序输出。在程序中记录输入次序,在重载运算符的时候注意比较俩的次序,我在这里贡献了多次WA。

代码:

<span style="color:#1a5cc8;">#include<stdio.h>
#include<queue>
#include<string.h>
#include<string>
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstdlib>
#include <cstring>
using namespace std;

struct node//自定义优先队列的优先级
{
char name[200];
int priority,val,i;

bool operator < (const node a) const
{
if(priority!=a.priority)//先按照优先级比较
return a.priority < priority;
</span><span style="color:#ff0000;">else//比较输入顺序
{
return i>a.i;
}</span><span style="color:#1a5cc8;">
}
};

int main()
{
priority_queue<node>q;//开一个node型的优先队列
char com[200];
int k=0;
while(~scanf("%s",com))
{
node mes;
if(strcmp(com,"GET")==0)
{
if(!q.empty())
{
node t=q.top();
printf("%s %d\n",t.name,t.val);
q.pop();
}
else
{
printf("EMPTY QUEUE!\n");
}
}
else if(strcmp(com,"PUT")==0)
{
scanf("%s%d%d",mes.name,&mes.val,&mes.priority);
mes.i=++k;
q.push(mes);
}
}
return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: