您的位置:首页 > 其它

hdu1068 二分图的最大独立集

2015-03-12 20:41 323 查看


Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8106    Accepted Submission(s): 3713


Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying
the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students

the description of each student, in the following format

student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...

or

student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.

For each given data set, the program should write to standard output a line containing the result.

 

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

 

Sample Output

5
2

 

此题由于关系只可能发生在男女之间,因此将集合分成男女两个部分,所以此题很明显是二分图。然而求二分图的最大独立集并不是NP的,因为二分图中有个定理:最小点覆盖数=最大匹配数,而我们知道最大独立集+最小点覆盖=|V|,因此最大独立集=|V|-最大匹配数。
注意:这里并没有将集合分成男女,而是将男女看成一个X部和Y部,这样a匹配b,必然会b匹配a,因此最大匹配数要除以2,就是原图的最大匹配数。

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 1010
using namespace std;

int adj[Maxn][Maxn];
int match[Maxn];
int vis[Maxn];
int x,y;
int deep;
bool dfs(int u){
for(int v=1;v<=y;v++){
if(adj[u][v]&&vis[v]!=deep){
vis[v]=deep;
if(match[v]==-1||dfs(match[v])){
match[v]=u;
return true;
}
}
}
return false;
}
int hungary(){
memset(match,-1,sizeof match);
memset(vis,-1,sizeof vis);
int ans=0;
for(int i=1;i<=x;i++){
deep=i;
if(dfs(i)) ans++;
}
return ans;
}
int main()
{
int n,m,a;
while(cin>>n){
memset(adj,0,sizeof adj);
for(int i=0;i<n;i++){
scanf("%*d: (%d)",&m);
for(int j=0;j<m;j++){
cin>>a;
adj[i+1][a+1]=1;
}
}
x=y=n;
printf("%d\n",n-hungary()/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: