您的位置:首页 > 其它

PAT 1070. Mooncake (25)

2015-03-12 17:23 411 查看
Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of
the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can
be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive
inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.
Sample Input:
3 200
180 150 100
7.5 7.2 4.5

Sample Output:
9.45


//贪心算法,寻找最大效益
#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

struct Mooncake
{
float amounts;
float prices;
bool operator < (const Mooncake &moon) const
{
return prices * moon.amounts > moon.prices * amounts;
}
};
vector<Mooncake> mooncake;
//注意数据输入的类型,n和d为正整数,但是prices, amounts都是整数,可能为小数
//当设置amounts为int类型时,提交会有一个案例不通过,更改为浮点类型,则案例全部通过
int main(void)
{
int n, d;
scanf("%d%d", &n, &d);
mooncake.resize(n);
for (int i = 0; i < n; ++i)
scanf("%f", &mooncake[i].amounts);
for (int i = 0; i < n; ++i)
scanf("%f", &mooncake[i].prices);
sort(mooncake.begin(), mooncake.end());
int i = 0;
float sum = 0;
while (i < n)
{
if (mooncake[i].amounts < d)
{
sum += mooncake[i].prices;
d -= mooncake[i].amounts;
}
else
{
sum += mooncake[i].prices  * d/ mooncake[i].amounts;
break;
}
++i;
}
printf("%.2f\n", sum);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: