您的位置:首页 > 其它

杭电1020-Encoding

2015-03-11 21:26 435 查看
[align=left]Problem Description[/align]
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded
to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be
ignored.

[align=left]Input[/align]
The first line contains an integer N (1 <= N
<= 100) which indicates the number of test cases.
The next N lines contain N strings. Each string consists of only
'A' - 'Z' and the length is less than 10000.

[align=left]Output[/align]
For each test case, output the encoded string in a
line.

[align=left]Sample Input[/align]

2
ABC

ABBCCC

[align=left]Sample Output[/align]
ABC
A2B3C

#include <cstdlib>
#include <iostream>
#include <string>
using namespace std;

int main(int argc, char *argv[])
{
int n,len,num,i;
cin>>n;
string s;
char temp;
while(n--)
{
cin>>s;
len=s.length();
temp=s[0];
num=1;;
for(i=1;i<len;i++)
{
if(temp==s[i])
num++;
else
{
if(num!=1)
cout<<num<<temp;
else
cout<<temp;

num=1;
temp=s[i];
}
}
if(num!=1)
cout<<num<<temp;
else
cout<<temp;

cout<<endl;
}
system("PAUSE");
return EXIT_SUCCESS;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: