您的位置:首页 > 其它

HDU 5011-Game(尼姆博弈)

2015-03-11 20:32 267 查看
Game
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU
5011

Appoint description:
System Crawler (2015-03-07)

Description

Here is a game for two players. The rule of the game is described below:

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing)

● If after a player's turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.

Input

There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 10 5) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer a i(a i < 2 31) means there are a i beads
in the i-th pile.

Output

For each test case, if the first player can win the game, ouput "Win" and if he can't, ouput "Lose"

Sample Input

1
1
2
1 1
3
1 2 3


Sample Output

Win
Lose
Lose


题意:至少拿走一颗棋子以后,该堆剩下的能分成两堆。

思路:尼姆博弈,但是和尼姆博弈有一点点不同,那就是剩下的能平均分成两堆,但是对后来的结果也没什么影响。

下面简单说一下尼姆博弈:

指的是一个游戏,目前有任意堆石子,每堆的石子都是任意的,双方轮流从中取石子,有如下规则:

1,每一步只能从某一堆取走至少一枚石子;

2,谁取到最后一次石子,谁胜利。

结论:假设有n堆物品,每堆物品有a[i]件,若a[0]^a[1]^a[2]^........a[n-1]!=0 先手必胜,否则必败。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
long long a[100010];
int main()
{
int n,i;
long long sum;
while(~scanf("%d",&n)){
sum=0;
memset(a,0,sizeof(a));
for(i=0;i<n;i++){
scanf("%lld",&a[i]);
sum^=a[i];
}
if(!sum)
printf("Lose\n");
else
printf("Win\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: