您的位置:首页 > 其它

hdu 2594 Simpsons’ Hidden Talents ( kmp )

2015-03-11 16:32 387 查看

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3508 Accepted Submission(s): 1307



Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.

Marge: Yeah, what is it?

Homer: Take me for example. I want to find out if I have a talent in politics, OK?

Marge: OK.

Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix

in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton

Marge: Why on earth choose the longest prefix that is a suffix???

Homer: Well, our talents are deeply hidden within ourselves, Marge.

Marge: So how close are you?

Homer: 0!

Marge: I’m not surprised.

Homer: But you know, you must have some real math talent hidden deep in you.

Marge: How come?

Homer: Riemann and Marjorie gives 3!!!

Marge: Who the heck is Riemann?

Homer: Never mind.

Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.


Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.


Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.

The lengths of s1 and s2 will be at most 50000.


Sample Input
clinton
homer
riemann
marjorie




Sample Output
0
rie 3




Source
HDU 2010-05 Programming Contest



题目大意: 给出两个字符串S1和S2,求取S1的前缀与S2的后缀中相同的且长度最大的串及其长度

将两个字符串连接,中间用不出现的字符间隔,直接kmp求取next数组,next[len]即为所求

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#define MAX 50007

using namespace std;

char s1[MAX<<1],s2[MAX];

void get_next ( char p[] , int next[] )
{
    int i = 0 , k = -1 , len = strlen (p);
    next[0] = -1;
    while ( i < len )
        if ( k == -1 || p[i] == p[k] ) 
            i++,k++,next[i] = k;
        else k = next[k];
}

void solve ( char s[] )
{
    int len = strlen ( s );
    int next[MAX<<1];
    get_next ( s , next );
    if ( next[len] )
    {
        for ( int i = 0 ; i < next[len] ; i++ )
            printf ( "%c" , s[i] );
        printf ( " " );
    }
    printf ( "%d\n" , next[len] );
}

int main ( )
{
    while ( ~scanf ( "%s" , s1 ) )
    {
        scanf ( "%s" , s2 );
        int len1 = strlen(s1);
        int len2 = strlen(s2);
        for ( int i = 0 ; i < len2 ; i++ )
            s1[i+len1+1] = s2[i];
        s1[len1] = '#';
        s1[len1+len2+1] = 0;
        solve ( s1 );
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: