您的位置:首页 > 其它

UVA - 10115 Automatic Editing

2015-03-09 23:52 274 查看
A - A

Description

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements,
within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.banbab
2.bababe
3.anaany
4.ba bhind the g
To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by thereplace-by string, then try to perform the same replacement again on the new text.
Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for afind string, you always start searching at the beginning
of the text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat
and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times,
and then rule 4 was used once.

BeforeAfter
banana boatbabana boat
babana boatbababa boat
bababa boatbeba boat
beba boatbehind the goat
Input

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of
lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit.

Output

For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit
process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

Sample Input

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0


Sample Output

behind the goat
shoe or shop


Hint

when u read a line of string after an int, u can use following codes, like
scanf("%d",&t);getchar();gets(str);
or u may read some unexpected words

/*
coder: Shawn_Xue
date: 2015.3.9
result: AC
description: UVA - 10115 Automatic Editing
*/
#include <stdio.h>
#include <string.h>

int main()
{
int n;
char find[80][150], re[80][150], str[500] = {'\0'}, tmp[500] = {'\0'};//str,tmp必须足够大,否则RE

while(scanf("%d", &n) == 1 && n)
{
getchar();          //  消去回车
for(int i = 0; i < n; i ++)
{
gets(find[i]);
gets(re[i]);
}

gets(str);

for(int i = 0; i < n; i ++)
{
if(strstr(str, find[i]) != NULL)    //  判断是否存在find[i]
{
char *p = strstr(str, find[i]);
int len = strlen(find[i]);  //  计算find后字符长度

strcpy(tmp, p+len);         //  保存find后字符入tmp
/*  点睛之笔   */
*p = '\0';                  //  替换p指向的字符为'\0',截断find后字符
strcat(str, re[i]);         //  re中的字符连接在str前半部分之后
strcat(str, tmp);           //  将tmp中保存的find后字符连接在str后
i--;                        //  再次循环,检查本次find[i]
}
}
puts(str);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: