您的位置:首页 > 其它

POJ2586 Y2K Accounting Bug(贪心)

2015-03-09 20:36 471 查看

Y2K Accounting Bug

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10975Accepted: 5520
Description
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how
many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost
sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input
Input is a sequence of lines, each containing two positive integers s and d.
Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input
59 237
375 743
200000 849694
2500000 8000000


Sample Output
116
28
300612
Deficit


题目大意:

12个月中,或固定盈余s,或固定亏损d. 但记不得哪些月盈余,哪些月亏损,只能记得连续5个月的代数和总是亏损(<0为亏损),而一年中只有8个连续的5个月,分别为1~5,2~6,…,8~12,问全年是否可能盈利?若可能,输出可能最大盈利金额,否则输出“Deficit".

解题思路:

(参考小優YoU的解题思路 http://blog.csdn.net/lyy289065406/article/details/6642603)
先处理处理完1~5月后,剩下的月份可以根据“连续5个月经营之和为亏损”这个条件进行确定亏损还是盈利。

本题的贪心选择每次仅仅选取其中一种情况(1~5月),因为之后月份无需再选择,所以每次总共只做了一次贪心选择。

实际上;只要讨论5种情况即可;(任一月固定盈余s,或固定亏损d).

SSSSDSSSSDSS 4s<d 保证“连续5个月必亏损”,每连续5个月种至少1个月D,

保证可能有全年最大盈余,每连续5个月中至多4个月S

SSSDDSSSDDSS 3s<2d 保证“连续5个月必亏损”,每连续5个月种至少2个月D,

保证可能有全年最大盈余,每连续5个月中至多3个月S

SSDDDSSDDDSS 2s<3d 保证“连续5个月必亏损”,每连续5个月种至少3个月D,

保证可能有全年最大盈余,每连续5个月中至多2个月S

SDDDDSDDDDSD s<4d 保证“连续5个月必亏损”,每连续5个月种至少4个月D,

保证可能有全年最大盈余,每连续5个月中至多1个月S

DDDDDDDDDDDD s>=4d 保证“连续5个月必亏损”,每连续5个月种至少5个月D,

每月亏损,此情况全年必亏损

要注意的是,前4种情况都仅仅是“可能有全年的盈余”,而不是“一定有全年的盈余”。

但是若果一旦有盈余,必定是最大盈余

把5种情况可以归纳为关于s的判定条件:

0 <= s <1/4d 每连续5个月种至少1个月D

1/4d <= s < 2/3d 每连续5个月种至少2个月D

2/3d <= s < 3/2d 每连续5个月种至少3个月D

3/2d <= s < 4d 每连续5个月种至少4个月D

4d <= s 全年各月必亏损

代码如下:

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
double s,d;
int res;
bool flag;
//freopen("111","r",stdin);
while(cin>>s>>d)
{
flag = false;
if(s < d/4 && s >=0)
{
res = 10 * s - 2 * d;
if(res < 0)
{
flag = true;
}
}
else if(s < 0.66666 * d && s >= d/4)
{
res = 8 * s - 4 * d;
if(res < 0)
{
flag = true;
}
}
else if(s < 1.5 * d && s >= 0.6666 * d)
{
res = 6 * s - 6 * d;
if(res < 0)
{
flag = true;
}
}
else if(s < 4 * d && s >=1.5 * d)
{
res = 3 * s - 9 * d;
if(res < 0)
{
flag = true;
}
}
else if(s >= 4 * d)
{
flag = true;
}
if(flag)
{
cout<<"Deficit"<<endl;
}
else
{
cout<<res<<endl;
}
}
return 0;
}


运行结果:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: