您的位置:首页 > 其它

(heu step 6.1.1)Constructing Roads(最小生成树模板题:求让n个点连通的最小费用)

2015-03-09 20:17 393 查看
题目:

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 207 Accepted Submission(s): 135
 
[align=left]Problem Description[/align]There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 
[align=left]Input[/align]The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 
[align=left]Output[/align]You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 
[align=left]Sample Input[/align]
3
0 990 692
990 0 179
692 179 0
1
1 2
 
[align=left]Sample Output[/align]
179
 
 
[align=left]Source[/align]kicc 
[align=left]Recommend[/align]Eddy 
题目分析:
               kruscal求最小生成树,简单题。需要注意一下的以下的情况:
1)有的路已经修好的处理方式:将该条边的权值置为0.
map[a][b] = map[b][a] = 0;//对于已经存在的边,我们把他的权值置为0即可

2)连接信息由矩阵转换成边的形式。
int cnt = 1;
for(i = 1 ; i <= n ; ++i){//将链接信息有矩阵的形式转换成边的形式
for(j = 1 ; j <= i ; ++j){
edges[cnt].begin = i;
edges[cnt].end = j;
edges[cnt++].weight = map[i][j];
}
}

代码如下:
/*
* a.cpp
*
* Created on: 2015年3月9日
* Author: Administrator
*/

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

const int maxn = 101;

struct Edge{//边
int begin;//起点
int end;//终点
int weight;//边的权值
}edges[maxn*maxn];

int father[maxn];
int map[maxn][maxn];

/**
* 求包含a结点的并查集的根
*/
int find(int a){
if(a == father[a]){
return a;
}

return father[a] = find(father[a]);
}

/**
* 使用kruscal来求最小生成树.
* 模板
*/
int kruscal(int count){
int i;
for(i = 1 ; i < maxn ; ++i){
father[i] = i;
}

int sum = 0;

for(i = 1 ; i <= count ; ++i){
int fx = find(edges[i].begin);
int fy = find(edges[i].end);

if(fx != fy){//如果他们还没有连通
father[fx] = fy;//则让他们连通
sum += edges[i].weight;//将这条路的费用加到修路总费用中
}
}

return sum;
}

bool cmp(const Edge& a, const Edge& b){
return a.weight < b.weight;
}

int main(){
int n;
while(scanf("%d",&n)!=EOF){
int i;
int j;
for(i = 1 ; i <= n ; ++i){//一矩阵的形式读入连接信息
for(j = 1 ; j <= n ; ++j){
scanf("%d",&map[i][j]);
}
}

int m;
scanf("%d",&m);
while(m--){
int a,b;
scanf("%d%d",&a,&b);
map[a][b] = map[b][a] = 0;//对于已经存在的边,我们把他的权值置为0即可
}

int cnt = 1;
for(i = 1 ; i <= n ; ++i){//将链接信息有矩阵的形式转换成边的形式
for(j = 1 ; j <= i ; ++j){
edges[cnt].begin = i;
edges[cnt].end = j;
edges[cnt++].weight = map[i][j];
}
}

cnt -= 1;//用于处理++导致的边数多1的情况

sort(edges+1,edges+1+cnt,cmp);//这就体现了kruscal中的贪心的思想

printf("%d\n",kruscal(cnt));
}

return 0;
}


                
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: