您的位置:首页 > 其它

uvaoj 401 Palindromes

2015-03-08 19:19 323 查看
************************************************题目描述***************************************************

UVA - 401

Palindromes

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of
the string is changed to its reverse (if it has a reverse) and the
string is read backwards the result is the same as the original string.
For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.



A mirrored palindrome is a string that meets the criteria of a regular
palindrome and the criteria of a mirrored string. The string "ATOYOTA"
is a mirrored palindrome because if the string is read backwards, the
string is the same as the original and because if each of the characters
is replaced by its reverse and the result is read backwards, the result
is the same as the original string.



Of course,"A","T", "O", and "Y" are all their own reverses.



A list of all valid characters and their reverses is as follows.



Character

Reverse

Character

Reverse

Character

Reverse

A

A

M

M

Y

Y

B

N

Z

5

C

O

O

1

1

D

P

2

S

E

3

Q

3

E

F

R

4

G

S

2

5

Z

H

H

T

T

6

I

I

U

U

7

J

L

V

V

8

8

K

W

W

9

L

J

X

X

Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.


Input


Input consists of strings (one per line) each of which will consist of
one to twenty valid characters. There will be no invalid characters in
any of the strings. Your program should read to the end of file.


Output


For each input string, you should print the string starting in column 1
immediately followed by exactly one of the following strings.



STRING

CRITERIA

" -- is not a palindrome."

if the string is not a palindrome and is not a mirrored string

" -- is a regular palindrome."

if the string is a palindrome and is not a mirrored string

" -- is a mirrored string."

if the string is not a palindrome and is a mirrored string

" -- is a mirrored palindrome."

if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.



In addition, after each output line, you must print an empty line.


Sample Input

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA


Sample Output

NOTAPALINDROME -- is not a palindrome.

ISAPALINILAPASI -- is a regular palindrome.

2A3MEAS -- is a mirrored string.

ATOYOTA -- is a mirrored palindrome.


Hint

use the C++'s class of string will be convenient, but not a must

Source

Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 6. String Processing :: Ad Hoc String Processing
Root ::
AOAPC I: Beginning Algorithm Contests (Rujia Liu) ::
Volume 1. Elementary Problem Solving ::
String

Root ::
AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) ::
Chapter 3. Arrays and Strings ::
Examples

Root ::
Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) ::
Introduction ::
Ad Hoc Problems ::
Palindrome

Root ::
Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) ::
Introduction ::
Ad Hoc Problems - Part 1 ::
Palindrome / Anagram

***************************************************************************************************************************
###############################################程序代码################################################
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

int main()
{
char s[20],q[20];
char a[21] = {'A','E','H','I','J','L','M','O','S','T','U','V','W','X','Y','Z','1','2','3','5','8'};
char b[21] = {'A','3','H','I','L','J','M','O','2','T','U','V','W','X','Y','5','1','S','E','Z','8'};
while(cin>>s) {
int k,i,f1=1,f2=1,j,p;
k = strlen(s);
p = strlen(a);
for(i=0; i<k; i++) {
if(s[i] != s[k-i-1]) {
f1 = 0;
break;
}
}
for(i=0; i<k; i++) {
for(j=0; j<p; j++) {
if(s[i] == a[j]) {
q[i] = b[j];
break;
}
}
if(q[i] != s[k-i-1]) {
f2 = 0;
break;
}

}
if(f1 != 1 && f2 != 1) {
printf("%s -- is not a palindrome.\n\n",s);
}
if(f1 == 1 && f2 != 1) {
printf("%s -- is a regular palindrome.\n\n",s);
}
if(f1 != 1 && f2 == 1) {
printf("%s -- is a mirrored string.\n\n",s);
}
if(f1 == 1 && f2 == 1) {
printf("%s -- is a mirrored palindrome.\n\n",s);
}

}
return 0;
}
####################################################################################################
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: