您的位置:首页 > 其它

题目1002:Grading

2015-03-08 18:04 281 查看
时间限制:1 秒
内存限制:32 兆
特殊判题:
提交:16499
解决:4267

题目描述:
Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other,
a judge is invited to make the final decision. Now you are asked to write a program to help this process.

For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:

• A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.

• If the difference exceeds T, the 3rd expert will give G3.

• If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.

• If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.

• If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:
Each input file may contain more than one test case.

Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:
For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18


样例输出:
14.0


来源:
2011年浙江大学计算机及软件工程研究生机试真题

要注意是“读文件”(Each input file may contain more than one test case.),所以要有EOF,读完文件的标志。

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
using namespace std;

int main()
{

int p=20,t=2,g1=16,g2=13,g3=10,gj=18;

while(scanf("%d %d %d %d %d %d",&p,&t,&g1,&g2,&g3,&gj)!=EOF)
{
double grade;
int a = abs(g1-g2),b=abs(g3-g1),c=abs(g3-g2);
if(a<=t)
grade = (g1+g2)*1.0/2;
else
{
if(b<=t&&c<=t)
{
int max =g1;
if(g2>max) max = g2;
if(g3>max) max = g3;
grade = max*1.0;
}
else if(b<=t)
grade = (g1+g3)*1.0/2;
else if(c<=t)
grade = (g2+g3)*1.0/2;
else
grade = gj*1.0;
}
printf("%.1lf\n",grade);
}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: