您的位置:首页 > 产品设计 > UI/UE

POJ 1947 Rebuilding Roads (树形dp 经典题)

2015-03-08 17:10 239 查看
Rebuilding Roads
Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 9499Accepted: 4317
Description
The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there
is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree.

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.
Input
* Line 1: Two integers, N and P

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads.

Output
A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated.

Sample Input
11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output
2

Hint
[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.]

Source
USACO 2002 February

题目链接:http://poj.org/problem?id=1947

题目大意:一颗含有n个结点的树,求减去最少的边使得该树只含有p个结点

题目分析:典型的树形dp,在树上进行动态规划,设dp[s][i]表示以s为根的子树含有i个结点需要删去的边数,则得到转移方程:

对于i的子树k:

1.不加子树k,dp[s][i] = dp[s][i] + 1 (不加子树k,相当于删去一条边)

2.加子树k,dp[s][i] = min(dp[s][j] + dp[k][i - j]) (1<= j <= i) (以s为根的树的结点数加上其子树的结点数等于i)

最后答案就是在dp[i][m]中取小,要注意的一点是,如果i不是根,值还需要+1,因为要脱离原来的根,还要去掉一条边

这里需要注意,dp过程是自下而上的,也就是从叶子到根,而不是从根到叶子

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const INF = 0x3fffffff;
int const MAX = 155;

struct Edge
{
    int to, next;
}e[MAX * MAX / 2];

int n, m;
int head[MAX], cnt, root;
int fa[MAX], dp[MAX][MAX];

void Add(int x, int y)  //加边
{
    e[cnt].to = y;
    e[cnt].next = head[x];
    head[x] = cnt++;
}

void DFS(int u)
{
    for(int i = 0; i <= m; i++) //初始化为无穷大
        dp[u][i] = INF;               
    dp[u][1] = 0;               //根结点本就一个点,不需要减边
    for(int i = head[u]; i != -1; i = e[i].next)  //同层
    {
        int v = e[i].to;    //u的子树
        DFS(v);
        for(int j = m; j >= 1; j--) 
        {
            for(int k = 0; k < j; k++)
            {
                if(k)   //不加子树k
                    dp[u][j] = min(dp[u][j], dp[u][j - k] + dp[v][k]);
                else    //加上子树k
                    dp[u][j] = dp[u][j] + 1;
            }
        }
    }
}

int main()
{
    scanf("%d %d", &n, &m);
    cnt = 0;
    memset(fa, -1, sizeof(fa));
    memset(head, -1, sizeof(head));
    for(int i = 1; i < n; i++)
    {
        int x, y;
        scanf("%d %d", &x, &y);
        Add(x, y);
        fa[y] = x;
    }
    for(root = 1; fa[root] != -1; root = fa[root]);
    DFS(root);
    int ans = dp[root][m];
    for(int i = 1; i <= n; i++)     //除了根节点,其他节点要想成为独立的根,必先与父节点断绝关系,所以要先加1
        ans = min(ans, dp[i][m] + 1);
    printf("%d\n",ans);    
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: