您的位置:首页 > 其它

POJ 1094 Sorting It All Out (拓扑排序)

2015-03-08 15:54 369 查看
Sorting It All Out
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 28766Accepted: 9965
Description
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D
implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26.
The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation
consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.

Sorted sequence cannot be determined.

Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source
East Central North America 2001

题目链接:http://poj.org/problem?id=1094

题目大意:根据给出的点的大小关系,判断是否能够确定所有点构成的有序序列,不能输出在第几个关系后出现矛盾

题目分析:拓扑排序,排完后三种情况

1.图中存在环,则关系矛盾

2.图中不存在环,但排序出来的序列中元素个数小于总的元素个数,则序列不能够确定

3.图中不存在环,排序出的序列中元素个数等于总的元素个数,则序列被唯一确定

#include <cstdio>
#include <cstring>
#include <stack>
using namespace std;
int const MAX = 26;
int m, n;
int map[MAX][MAX], ind[MAX], tmp[MAX];
char seq[MAX], s[5];

int TopoSort()
{
    bool flag = false;
    int len = 0;
    memcpy(tmp, ind, sizeof(ind));
    stack <int> s;
    for(int i = 0; i < n; i++)
        if(!tmp[i])
            s.push(i);
    while(!s.empty())
    {
        if(s.size() > 1)
            flag = true;    //序列不确定
        int pos = s.top();
        s.pop();
        seq[len ++] = pos + 'A';   
        for(int i = 0; i < n; i++)
            if(map[pos][i] && --tmp[i] == 0)
                s.push(i);
    }
    if(len != n)    //不能拓扑排序,即有环
        return 1;
    else if(flag)   //不能确定
        return 2;
    return 0;       //确定
}

int main()
{
    while(scanf("%d %d", &n, &m) != EOF && (m + n))
    {
        bool determined = false, inconsistency = false;
        memset(map, 0, sizeof(map));
        memset(ind, 0, sizeof(ind));
        memset(seq, 0, sizeof(seq));
        for(int i = 1; i <= m; i++)
        {
            scanf("%s", s);
            if(!determined && !inconsistency)
            {
                int x = s[0] - 'A';
                int y = s[2] - 'A';
                if(map[y][x])   //存在反向边,则发现矛盾
                {
                    inconsistency = true;
                    printf("Inconsistency found after %d relations.\n", i);
                    continue;
                }
                if(!map[x][y])
                {
                    map[x][y] = 1;
                    ind[y] ++;
                }
                int get = TopoSort();
                if(get == 0)    //确定
                {
                    printf("Sorted sequence determined after %d relations: %s.\n", i, seq);
                    determined = true;
                }
                else if(get == 1)//矛盾
                {
                    printf("Inconsistency found after %d relations.\n", i);
                    inconsistency = true;
                }
            }

        }
        if(!determined && !inconsistency)//不确定
            printf("Sorted sequence cannot be determined.\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: