您的位置:首页 > 其它

zoj_1188 DNA Sorting

2015-03-08 15:41 323 查看
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this
measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while
the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order,
but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank
line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file.

Sample Input
1
10 6

AACATGAAGG

TTTTGGCCAA

TTTGGCCAAA

GATCAGATTT

CCCGGGGGGA

ATCGATGCAT

Sample Output

CCCGGGGGGA

AACATGAAGG

GATCAGATTT

ATCGATGCAT

TTTTGGCCAA

TTTGGCCAAA

分析:
本题是字符串排序问题,字符串内部按照ASCII大小排序,字符串之间按照倒位数量来排序。
倒位数量,就是该字符串中,每个字符与它右边的字符相比,逆序次数的总和。
排序时,如果两行字符串的倒位数量相同,那么按照原先输入时的顺序排序;输出时,每块之间需要空一行。

关键问题是:字符串内部如何排序?
首先要想到,要得到倒位数量,需要一个变量记录字符对比的次数,如果当前字符比右边字符大,该变量就加1,否则变量不变。
假设字符串一的倒位数量是c1,字符串二的倒位数量是c2.
那么字符串之间是如何比较的呢?
答案给出的比较方法中:return c1!=c2 ? c1<c2:c1<c2;
简化可得:return c1<c2;

另外还需要温习一下sort函数:
默认情况下为升序排列, sort(array,array+n);
也可以重载该函数,自定义排序方法cmp, sort(array,array+n,cmp);
例如降序排列:
bool cmp( int a, int b)
{
return a>b;
}

Answer
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

bool comp(const string &s1, const string &s2)
{
int i,j,k;
int c1=0,c2=0;
//计算s1需要移动的次数c1
for(i=0;i<s1.size();i++)
{
for(j=i+1;j<s1.size();j++)
{
if(s1[i]>s1[j]) c1++;
}
}
//计算s1需要移动的次数c1
for(i=0;i<s2.size();i++)
{
for(j=i+1;j<s2.size();j++)
{
if(s2[i]>s2[j]) c2++;
}
}
//如果两行字符串移动的次数相同,那么按照原先固有的位置排序
return c1<c2;
}
int main()
{
string s;
vector<string>v;
int n,a,b;//n为组数,a为字符串长度,b为字符串行数
int i,j,k;
int p=0;//组数从0开始

cin>>n;
for(i=0;i<n;i++)
{
cin.clear();
cin>>a>>b;
v.clear();
p++;
for(j=0;j<b;j++)
{
cin>>s;
v.push_back(s);
}
//按comp排序规则排序
sort(v.begin(),v.end(),comp);
if(p!=1) cout<<endl; //如果不是第一组,产生一个新空行
for(k=0;k<v.size();k++)
{
cout<<v[k]<<endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: