您的位置:首页 > 其它

HDU 2095--Find your present (2) 【set】

2015-03-07 22:50 381 查看

find your present (2)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 17493 Accepted Submission(s): 6684



Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and
your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card
number of 3, because 3 is the number that different from all the others.


Input
The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.


Output
For each case, output an integer in a line, which is the card number of your present.


Sample Input
5
1 1 3 2 2
3
1 2 1
0




Sample Output
3
2

HintHint 
use scanf to avoid Time Limit Exceeded




题意:

给你n个数字,已知只有一个数字出现了奇数次,其他数字都出现了偶数次,要求你找出这个特别的数字。

用的set ,想学习set的朋友可以看一下这篇博客,写的非常好:http://www.cnblogs.com/BeyondAnyTime/archive/2012/08/13/2636375.html

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <set>
using namespace std;

int main(){
    int n,m;
    set<int>s;
    while(scanf("%d",&n),n){
        s.clear();
        while(n--){
            scanf("%d",&m);
            if(s.find(m)!=s.end())
                s.erase(m);
            else
                s.insert(m);
        }
        printf("%d\n",*s.begin());
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: