您的位置:首页 > 其它

POJ 1724 ROADS(DFS剪枝)

2015-03-06 21:05 399 查看
ROADS

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11246Accepted: 4164
Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).

Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.

The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :

S is the source city, 1 <= S <= N

D is the destination city, 1 <= D <= N

L is the road length, 1 <= L <= 100

T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.
Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.

If such path does not exist, only number -1 should be written to the output.

Sample Input
5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output
11

求1到n的最短路,其中每条边还有一定的花费,在硬币数k有限,在花费k内求出最短路劲,如若没有输出-1

用DFS从1开始搜就行,需注意要进行剪枝 否则TLE

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <stdlib.h>
#include <algorithm>
#include <cmath>
#include <map>
#define inf 0x3f3f3f3f
#define N 110
using namespace std;
struct node
{
    int s,t,l,d;
    int next;
}q[N*N];
int head
;
bool b
;
int k,n,r;
int ans;
void DFS(int x,int s1,int s2)
{
    if(x==n)
    {
        ans=min(s1,ans);
        return ;
    }
    for(int i=head[x]; i!=-1; i=q[i].next)
    {
        if(!b[q[i].d] && s2>=q[i].t && s1+q[i].l<ans && s2-q[i].t>=0)
        {
            b[q[i].d] = true;
            DFS(q[i].d,s1+q[i].l,s2-q[i].t);
            b[q[i].d]=false;
        }
    }
}
int main()
{
    while(~scanf("%d",&k))
    {
        memset(head,-1,sizeof(head));
        memset(b,false,sizeof(b));
        scanf("%d%d",&n,&r);
        for(int i=0; i<r; i++)
        {
            int S,D,L,T;
            scanf("%d%d%d%d",&S,&D,&L,&T);
            q[i].s=S;
            q[i].d=D;
            q[i].l=L;
            q[i].t=T;
            q[i].next=head[S];
            head[S]=i;
        }
        b[1]=true;
        ans=inf;
        DFS(1,0,k);
        if(ans==inf) printf("-1\n");
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: